ERPS D-Link SNR Single ring

DGS 1510\20

create erps raps_vlan 10
config erps raps_vlan 10 timer holdoff_time 0 guard_time 50 wtr_time 5
config erps raps_vlan 10 rpl_port east
config erps raps_vlan 10 rpl_owner enable
config erps raps_vlan 10 ring_mel 7
config erps raps_vlan 10 revertive mode enable
config erps raps_vlan 10 ring_port west 16
config erps raps_vlan 10 ring_port east 17
config erps raps_vlan 10 protected_vlan add vlanid 100
config erps raps_vlan 10 protected_vlan add vlanid 200
config erps raps_vlan 10 protected_vlan add vlanid 300
config erps raps_vlan 10 state enable
enable erps
config erps log enable
config erps trap disable

SNR 2995

spanning-tree mst configuration
instance 0 vlan 1-99;101-199;201-299;301-4094
instance 1 vlan 100;200;300
exit
!
vlan 1;10;20;31-32;100;200;300
!
erps-ring ring
erps-instance 1
rpl port0 neighbour
protected-instance 1
control-vlan 10
exit
!
Interface Ethernet1/0/1
description To s300
switchport mode trunk
switchport trunk allowed vlan 10;20;100;200
switchport trunk native vlan 31
erps-ring ring port1
!
Interface Ethernet1/0/2
description To DGS
switchport mode trunk
switchport trunk allowed vlan 10;20;100;200
switchport trunk native vlan 32
erps-ring ring port0
!

SNR S300

spanning-tree mst configuration
instance 0 vlan 1-99;101-199;201-299;301-4094
instance 1 vlan 100;200;300
exit
!
vlan 1;10;20;31-32;100;200;300
!
erps-ring ring
erps-instance 1
protected-instance 1
control-vlan 10
exit
!
Interface Ethernet1/0/1
description To 2995
switchport mode trunk
switchport trunk allowed vlan 10;20;100;200
switchport trunk native vlan 31
erps-ring ring port0
!
Interface Ethernet1/0/2
description To DGS
switchport mode trunk
switchport trunk allowed vlan 10;20;100;200
switchport trunk native vlan 31
erps-ring ring port1
!

s300 vpls irb

В общем, я не знаю зачем я это сделал, но если вам нужен интегрированный роутинг на snr s300 вместе с vpls, то вопрос решается физической петлей между портами и следующим конфигом.

!
vlan 1;100;200;4001-4002
!
l3-interface care vlan
!
Interface Ethernet1/0/1
description loop to e1/0/2
switchport discard packet untag
switchport mode trunk
switchport trunk allowed vlan 100;200
switchport trunk native vlan 4001
!
Interface Ethernet1/0/2
description loop to e1/0/1
switchport access vlan 4002
xconnect vfi 100 mode vlan svid 100
xconnect vfi 200 mode vlan svid 200
!
Interface Ethernet1/0/3
description client local terminate
switchport access vlan 100
!
Interface Ethernet1/0/4
description client vpls terminate
xconnect vfi 100
!
vfi v100 100
!
vfi v200 200
!
interface Vlan100
ip address 10.100.0.1 255.255.255.0
!
interface Vlan200
ip address 10.200.0.1 255.255.255.0
!

В итоге получаем связь со шлюзом и с порта 3, и с порта 4. Могло бы получится вообще клёво, если бы порты 40г были полнофункциональными, а так — баловство.

Debian Squeeze to Stretch

vi /etc/apt/sources.list #replace content

deb http://ftp.de.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.de.debian.org/debian/ squeeze main contrib non-free

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# squeeze-updates, previously known as 'volatile'
deb http://ftp.de.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.de.debian.org/debian/ squeeze-updates main contrib non-free

apt-get update
apt-get upgrade
apt-get dist-upgrade

vi /etc/apt/sources.list #replace content

deb http://ftp.de.debian.org/debian wheezy main contrib non-free
deb-src http://ftp.de.debian.org/debian wheezy main contrib non-free
deb http://ftp.de.debian.org/debian wheezy-updates main contrib non-free
deb http://ftp.de.debian.org/debian-security wheezy/updates main contrib non-free

apt-get update
apt-get upgrade
apt-get dist-upgrade

reboot

vi /etc/apt/sources.list #replace content

deb http://ftp.de.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.de.debian.org/debian/ jessie main contrib non-free

deb http://httpredir.debian.org/debian jessie-updates main contrib non-free
deb-src http://httpredir.debian.org/debian jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

apt-get update
apt-get upgrade
apt-get dist-upgrade

reboot

vi /etc/apt/sources.list #replace content

deb http://httpredir.debian.org/debian stretch main contrib non-free
deb http://httpredir.debian.org/debian stretch-updates main contrib non-free
deb http://security.debian.org stretch/updates main contrib non-free

apt-get update
apt-get upgrade
apt-get dist-upgrade

reboot