Архив автора: vurd

s300 vpls irb

В общем, я не знаю зачем я это сделал, но если вам нужен интегрированный роутинг на snr s300 вместе с vpls, то вопрос решается физической петлей между портами и следующим конфигом.

!
vlan 1;100;200;4001-4002
!
l3-interface care vlan
!
Interface Ethernet1/0/1
description loop to e1/0/2
switchport discard packet untag
switchport mode trunk
switchport trunk allowed vlan 100;200
switchport trunk native vlan 4001
!
Interface Ethernet1/0/2
description loop to e1/0/1
switchport access vlan 4002
xconnect vfi 100 mode vlan svid 100
xconnect vfi 200 mode vlan svid 200
!
Interface Ethernet1/0/3
description client local terminate
switchport access vlan 100
!
Interface Ethernet1/0/4
description client vpls terminate
xconnect vfi 100
!
vfi v100 100
!
vfi v200 200
!
interface Vlan100
ip address 10.100.0.1 255.255.255.0
!
interface Vlan200
ip address 10.200.0.1 255.255.255.0
!

В итоге получаем связь со шлюзом и с порта 3, и с порта 4. Могло бы получится вообще клёво, если бы порты 40г были полнофункциональными, а так — баловство.

Debian Squeeze to Stretch

vi /etc/apt/sources.list #replace content

deb http://ftp.de.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.de.debian.org/debian/ squeeze main contrib non-free

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

# squeeze-updates, previously known as 'volatile'
deb http://ftp.de.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.de.debian.org/debian/ squeeze-updates main contrib non-free

apt-get update
apt-get upgrade
apt-get dist-upgrade

vi /etc/apt/sources.list #replace content

deb http://ftp.de.debian.org/debian wheezy main contrib non-free
deb-src http://ftp.de.debian.org/debian wheezy main contrib non-free
deb http://ftp.de.debian.org/debian wheezy-updates main contrib non-free
deb http://ftp.de.debian.org/debian-security wheezy/updates main contrib non-free

apt-get update
apt-get upgrade
apt-get dist-upgrade

reboot

vi /etc/apt/sources.list #replace content

deb http://ftp.de.debian.org/debian/ jessie main contrib non-free
deb-src http://ftp.de.debian.org/debian/ jessie main contrib non-free

deb http://httpredir.debian.org/debian jessie-updates main contrib non-free
deb-src http://httpredir.debian.org/debian jessie-updates main contrib non-free

deb http://security.debian.org/ jessie/updates main contrib non-free
deb-src http://security.debian.org/ jessie/updates main contrib non-free

apt-get update
apt-get upgrade
apt-get dist-upgrade

reboot

vi /etc/apt/sources.list #replace content

deb http://httpredir.debian.org/debian stretch main contrib non-free
deb http://httpredir.debian.org/debian stretch-updates main contrib non-free
deb http://security.debian.org stretch/updates main contrib non-free

apt-get update
apt-get upgrade
apt-get dist-upgrade

reboot

65k твики

Если много трафика приходится миррорить с линейной карты, чтобы не ходило через сап
no monitor session egress replication-mode centralized

Если надо выкинуть мультикаст в соседний vrf
ip multicast vrf test rpf select global group-list range

Электронный реле-регулятор РР-302

Проблема механического реле-регулятора на мотоцикле Урал М-66 и прочих 6-вольтовых мотоциклах не раз настигала всех владельцев данного аппарата. Начиная от банального загрязнения контактов и кончая сбитым настройкам, всё это приводит к неправильной работе механизма поддержания заряда аккумулятора.
Сейчас, в 2014 году, эту проблему можно очень просто решить — купить готовый электронный аналог или изготовить его самому. Если бы электроника была 12-вольтовая, то вопросов бы вообще не было, просто идешь в магазин и покупаешь реле от ВАЗ-а, но в нашем случае всё по другому. Как выяснилось, купить можно у чувака, который проспамил по всему инету и в дополнительной рекламе не нуждается. Собственно, я заказ у него экземпляр в корпусе, готовый к замене. Этот чувак из Луганск-а, а это означает, что доставка будет как минимум занимать один месяц. Мотоциклисты живут-то по три месяца, так что этот вариант нам подходит с натяжкой. Ну да ладно, запасное будет.
Вариант второй, найти схему и спаять, применив прямые руки. Вариант тоже сопряжен с трудностями, найти толковую схему практически не возможно. Ну, до текущего момента, ибо дядя Вурд решил сделать достоянием общественности эти тайные знания.

Схема
Схема от руки, хотел перерисовать в нормальном виде, но на новой системе нет нужной программы, а искать что-то другое или вырисовывать irf-ку руками мне не хочется. Так что, у нас здесь «ехать», «шашечек» не завозили.
scheme

Плата, вид со стороны пайки
Плюс монтаж, он должен быть именно таким, бронебойным.
bottom

Плата, вид со стороны деталей
Тупые вопросы почему у меня тут резисторы по 1 ватту, мы, пожалуй, опустим. Не было других.
tom

На мотоцикле всё удобно, ремонтопригодно
Хотя я не собираюсь его особо ремонтировать.
mount

mount2

Работает!
Зажжен дальний свет, холостой ход.
voltage

Настроено на 7.25 вольт. Настройка элементарная, нужно подобрать оптимальное соотношение для делителя напряжения между R4 и R2+R3. Напряжение для открытия транзистора, а значит отключения заряда батареи, должно быть 2.5 вольт. Т.е. в схеме 4700K — 2470К мы получаем на делителе 2.5 при 7.25 на батарее. Считаем тут — http://cxem.net/calc/divider_calc.php.
divider

Ну и главный гвоздь нашей программы — платы в формате Sprint Layout 6.
RR-302-EL-REV-3.2

pcb

Берем, пользуемся, говорим «спасибо».

P.S. Изначально схема не моя, я лишь поменял номиналы на подходящие для наших мотоциклов